We are happy to announce that cPanel, L.L.C. has released an update for EasyApache 4! Take a look at some highlights below, and then join us on Discord or Reddit to talk about this update and much more.
ea-apache2EA-9506: Do not start htcacheclean service if mod_cache_disk module is not loaded.
ea-libicuEA-9527: Update ea-libicu to 68.2. drop 67.
ea-php74EA-9517: Update ea-php74 to 7.4.14, drop 7.4.13 (with fix for CVE-2020-7071).
ea-php74-metaEA-9517: Update ea-php74 to 7.4.14, drop 7.4.13 (with fix for CVE-2020-7071).
ea-php80EA-9519: Update ea-php80 to 8.0.1, drop 8.0.0 (with fix for CVE-2020-7071).
ea-php80-metaEA-9519: Update ea-php80 to 8.0.1, drop 8.0.0 (with fix for CVE-2020-7071).
ea-ruby27-passengerZC-8196: Ensure pre-2.7 apps are configured for 2.4 so that they continue to use 2.4.ZC-8188: Configure python if python3 is not thereZC-8188: Provide /etc/cpanel/ea4/passenger.python.
ea-tomcat85EA-9505: Update ea-tomcat85 to 8.5.61, drop 8.5.60.
scl-php73EA-9518: Update scl-php73 to 7.3.26, drop 7.3.25 (with fix for CVE-2020-7071).
scl-php73-metaEA-9518: Update scl-php73 to 7.3.26, drop 7.3.25 (with fix for CVE-2020-7071).
scl-ruby24ZC-8143: Compile ruby 2.4 binary to work when called directly.
scl-ruby24-passengerZC-8188: Make python check verbose and explicitly for mod_passenger package.ZC-8188: Configure python if python3 is not there.ZC-8188: Provide /etc/cpanel/ea4/passenger.python.
This release includes a security patch that has been issued a fix for a CVE (Common Vulnerabilities and Exposures), the details of which are included below.
cPanel, L.L.C. has updated RPMs for EasyApache 4 with PHP versions 8.0.1, 7.4.14, and 7.3.26 and NodeJS version 10.23.1. This release addresses vulnerabilities related to CVE-2020-8265, CVE-2020-8287, CVE-2020-1971, and CVE-2020-7071. We strongly encourage all PHP 8.0 users to upgrade to version 8.0.1, all PHP 7.4 users to upgrade to version 7.4.14, all PHP 7.3 users to upgrade to version 7.3.26, and all NodeJS users to upgrade to version 10.23.1.
All versions of PHP 8.0 through 8.0.0.
All versions of PHP 7.4 through 7.4.13.
All versions of PHP 7.3 through 7.3.25.
All versions of NodeJS through 10.23.0.
The National Vulnerability Database (NIST) has given the following severity ratings to these CVEs:
CVE-2020-8265 – CRITICAL
Fixed bug related to CVE-2020-8265.