EasyApache 4 February 10 Release

We are happy to announce that cPanel, L.L.C. has released an update for EasyApache 4! Take a look at some highlights below, and then join us on Discord or Reddit to talk about this update and much more.

2021-2-10

ea-apache24-mod_pagespeed
EA-9560: Update to version 1.14.36.1
ea-nghttp2
EA-9573: Update ea-nghttp2 to 1.43.0, drop 1.42.0.
ea-php74
EA-9565: Update ea-php74 to 7.4.15, drop 7.4.14 (with fix for CVE-2021-21702).
ea-php74-meta
EA-9565: Update ea-php74 to 7.4.15, drop 7.4.14 (with fix for CVE-2021-21702).
ea-php80
EA-9574: Update ea-php80 to 8.0.2, drop 8.0.1 (with fix for CVE-2021-21702).
ea-php80-meta
EA-9574: Update ea-php80 to 8.0.2, drop 8.0.1 (with fix for CVE-2021-21702).
ea-tomcat85
EA-9566: Update ea-tomcat85 to 8.5.63, drop 8.5.61.
scl-php73
EA-9568: Update scl-php73 to 7.3.27, drop 7.3.26 (with fix for CVE-2021-21702).
scl-php73-meta
EA-9568: Update scl-php73 to 7.3.27, drop 7.3.26 (with fix for CVE-2021-21702).

This release includes a security patch that has been issued a fix for a CVE (Common Vulnerabilities and Exposures), the details of which are included below.

SUMMARY
cPanel, L.L.C. has updated RPMs for EasyApache 4 with PHP versions 8.0.2, 7.4.15, and 7.3.27. This release addresses vulnerabilities related to CVE-2021-21702. We strongly encourage all PHP 8.0 users to upgrade to version 8.0.2, all PHP 7.4 users to upgrade to version 7.4.15, and all PHP 7.3 users to upgrade to version 7.3.27.
 
 
AFFECTED VERSIONS
All versions of PHP 8.0 through 8.0.1.
All versions of PHP 7.4 through 7.4.14.
All versions of PHP 7.3 through 7.3.26.

 
SECURITY RATING
The National Vulnerability Database (NIST) has given the following severity ratings to these CVEs:
 

CVE-2021-21702 – MEDIUM

PHP 7.3.27
Fixed bug related to CVE-2021-21702.

PHP 7.4.15
Fixed bug related to CVE-2021-21702.

PHP 8.0.2
Fixed bug related to CVE-2021-21702.


SOLUTION
cPanel, L.L.C. has released updated RPMs for EasyApache 4 on February 10, 2021, with updated versions of PHP  7.3.27, 7.4.15, and 8.0.2. Unless you have enabled automatic RPM updates in your cron, update your system with either yum update or WHM’s Run System Update interface.

 
REFERENCES
https://nvd.nist.gov/vuln/detail/CVE-2021-21702
https://www.php.net/ChangeLog-7.php
https://www.php.net/ChangeLog-8.php

You can download the PGP Signed message below. 

EA4-2021-2-10-CVE.signedDownload

More Information

Information about all releases this year can be found in the 2020 EasyApache 4 Changelog and the EasyApache 4 Release Notes. To ensure that you receive up-to-date product news from cPanel, we encourage you to subscribe to the Product and Security updates mailing list on our website. You can also sign up for our EasyApache Development and EasyApache Production lists to see when updates are pushed for our RPMs, letting you know ahead of time what will be updated in each EasyApache release.

Original author: Tabby Worthington

Copyright

© Cpanel

WhatsApp explains what happens if you don't bend t...
EasyApache 4 February 4 Release
 

By accepting you will be accessing a service provided by a third-party external to https://divethewebcreations.biz/

Advertisement