EasyApache 4 Aug 21 Release

We are happy to announce that cPanel, L.L.C. has released an update for EasyApache 4! Take a look at some highlights below, and then join us on SlackDiscord, or Reddit to talk about this update and much more.

• ea-apache2
     • EA-8612: Update ea-apache2 from v2.4.39 to v2.4.41
     • EA-8588: Added default RequestReadTimeout for mod_reqtimeout
           CVE-2019-9517
           CVE-2019-10081  
           CVE-2019-10098
           CVE-2019-10092
           CVE-2019-10097
           CVE-2019-10082

• ea-apache2-config
     • EA-8610: Adjust pecl patch for CloudLinux to skip if alt-php in use

• ea-nghttp2
     • EA-8611: Update ea-nghttp2 from v1.39.1 to v1.39.2
          CVE-2019-9511
          CVE-2019-9513

• ea-nodejs10
     • EA-8608: Update ea-nodejs10 from v10.16.1 to v10.16.2

• ea-tomcat85
     • EA-8619: Update ea-tomcat85 from v8.5.40 to v8.5.43
         CVE-2019-10072:  Expand HTTP/2 timeout handling to include connection window exhaustion on write.

SUMMARY
cPanel, L.L.C. has updated RPMs for EasyApache 4 with Apache version 2.4.41, NGHTTP2 version 1.39.2, and Tomcat version 8.5.43. This release addresses vulnerabilities related to CVE-2019-10081, CVE-2019-9517, CVE-2019-10098, CVE-2019-10092, CVE-2019-10097, CVE-2019-10082, CVE-2019-9511, CVE-2019-9513, and CVE-2019-10072. We strongly encourage all Apache users to upgrade to version 2.4.41, all Tomcat users to upgrade to version 8.5.43, and all NGHTTP2 users to upgrade to version 1.39.2.

AFFECTED VERSIONS
All versions of Apache through 2.4.39
All versions of NGHTTP2 through 1.39.1
All versions of Tomcat through 8.5.42


SECURITY RATING
The National Vulnerability Database (NIST) has given the following severity ratings to these CVEs:

CVE-2019-10081 – MEDIUM
Apache 2.4.41
Fixed bug related to CVE-2019-10081

CVE-2019-9517 – MEDIUM
Apache 2.4.41
Fixed bug related to CVE-2019-9517

CVE-2019-10098 – MEDIUM
Apache 2.4.41
Fixed bug related to CVE-2019-10098

CVE-2019-10092 – MEDIUM
Apache 2.4.41
Fixed bug related to CVE-2019-10092

CVE-2019-10097 – MEDIUM
Apache 2.4.41
Fixed bug related to CVE-2019-10097

CVE-2019-10082 – MEDIUM
Apache 2.4.41
Fixed bug related to CVE-2019-10082

CVE-2019-9511 – MEDIUM
NGHTTP2 1.39.2
Fixed bug related to CVE-2019-9511

CVE-2019-9513 – MEDIUM
NGHTTP2 1.39.2
Fixed bug related to CVE-2019-9513

CVE-2019-10072 – MEDIUM
Tomcat 8.5.42
Fixed bug releated to CVE-2019-10072


SOLUTION
cPanel, L.L.C. has released updated RPMs for EasyApache 4 on August 21, 2019, with updated versions of Apache version 2.4.41, NGHTTP2 version 1.39.2, and Tomcat version 8.5.43. Unless you have enabled automatic RPM updates in your cron, update your system with either yum update or WHM’s Run System Update interface.


REFERENCES
https://nvd.nist.gov/vuln/detail/CVE-2019-10081
https://nvd.nist.gov/vuln/detail/CVE-2019-9517
https://nvd.nist.gov/vuln/detail/CVE-2019-10098
https://nvd.nist.gov/vuln/detail/CVE-2019-10092
https://nvd.nist.gov/vuln/detail/CVE-2019-10097
https://nvd.nist.gov/vuln/detail/CVE-2019-10082
https://nvd.nist.gov/vuln/detail/CVE-2019-9511
https://nvd.nist.gov/vuln/detail/CVE-2019-9513
https://nvd.nist.gov/vuln/detail/CVE-2019-10072
http://www.apache.org/dist/httpd/CHANGES_2.4
https://github.com/nghttp2/nghttp2/releases
http://tomcat.apache.org/tomcat-8.5-doc/changelog.html

For the PGP-signed message, please see EA4-2019-8-21-CVE.signed

More Information

Information about all releases this year can be found in the 2019 EasyApache 4 Changelog and the EasyApache 4 Release Notes. To ensure that you receive up-to-date product news from cPanel, we encourage you to subscribe to the Product and Security updates mailing list on our website. You can also sign up for our EasyApache Development and EasyApache Production lists to see when updates are pushed for our RPMs, letting you know ahead of time what will be updated in each EasyApache release.

Original author: Phil Hodges

Copyright

© Cpanel

cPanel & WHM Version 82 now in STABLE!
cPanel Unveils WebPros Summit 2019 (Formerly cPane...
 
Advertisement